# Table of Contents

<table>
<thead>
<tr>
<th>Part</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Foreword</td>
<td>0</td>
</tr>
<tr>
<td><strong>Part I</strong> Getting started</td>
<td>6</td>
</tr>
<tr>
<td>1</td>
<td>What is Remote Desktop Manager?</td>
</tr>
<tr>
<td>2</td>
<td>System requirements</td>
</tr>
<tr>
<td>3</td>
<td>Creating a new session</td>
</tr>
<tr>
<td>4</td>
<td>Configuring a session</td>
</tr>
<tr>
<td>5</td>
<td>Connecting to a session</td>
</tr>
<tr>
<td>6</td>
<td>Embedded / tabbed mode vs external mode</td>
</tr>
<tr>
<td>7</td>
<td>Group / folder management</td>
</tr>
<tr>
<td><strong>Part II</strong> Views</td>
<td>18</td>
</tr>
<tr>
<td>1</td>
<td>All sessions view</td>
</tr>
<tr>
<td>2</td>
<td>Opened view</td>
</tr>
<tr>
<td>3</td>
<td>Favorites</td>
</tr>
<tr>
<td>4</td>
<td>Most recently used</td>
</tr>
<tr>
<td>5</td>
<td>Application tools</td>
</tr>
<tr>
<td><strong>Part III</strong> Data source types</td>
<td>26</td>
</tr>
<tr>
<td>1</td>
<td>Overview</td>
</tr>
<tr>
<td>2</td>
<td>Managing a data source</td>
</tr>
<tr>
<td>3</td>
<td>Amazon S3</td>
</tr>
<tr>
<td>4</td>
<td>Dropbox</td>
</tr>
<tr>
<td>5</td>
<td>FTP</td>
</tr>
<tr>
<td>6</td>
<td>Microsoft Access</td>
</tr>
<tr>
<td>7</td>
<td>Microsoft SQL Server</td>
</tr>
<tr>
<td>8</td>
<td>mySQL</td>
</tr>
<tr>
<td>9</td>
<td>Remote Desktop Manager Online</td>
</tr>
<tr>
<td>10</td>
<td>Web</td>
</tr>
<tr>
<td>11</td>
<td>Xml</td>
</tr>
<tr>
<td><strong>Part IV</strong> Connection types</td>
<td>43</td>
</tr>
<tr>
<td>1</td>
<td>Overview</td>
</tr>
<tr>
<td>2</td>
<td>Citrix (ICA / HDX)</td>
</tr>
<tr>
<td>3</td>
<td>Command Line</td>
</tr>
<tr>
<td>4</td>
<td>Dameware Mini Remote Control</td>
</tr>
<tr>
<td>5</td>
<td>Ftp</td>
</tr>
<tr>
<td>6</td>
<td>HP RGS</td>
</tr>
</tbody>
</table>

© 2011 Devolutions inc.
Part V  Common features  52
1 Advanced description.............................................................. 52
2 Command line arguments...................................................... 53
3 Connection details................................................................. 54
4 Dashboard.............................................................................. 55
5 Options dialog........................................................................ 55
6 Keyboard shortcuts................................................................. 56
7 Quick connect.......................................................................... 57
8 Search / filter.......................................................................... 57
9 Security.................................................................................... 58
10 Session tools........................................................................... 59
11 Session variables................................................................. 61
12 System Tray icon................................................................. 62
13 Templates............................................................................... 63
14 VPN....................................................................................... 64

Part VI  Enterprise features  67
1 Attachments............................................................................. 67
2 Batch edit.................................................................................. 67
3 Connection events................................................................. 73
4 Session log............................................................................... 73
5 Credential repository........................................................... 75
6 Import sessions......................................................................... 77
7 Offline mode............................................................................ 79
8 Session script tools............................................................... 79
9 Sub connections........................................................................ 80
10 User management............................................................... 81
11 Wake-on-LAN........................................................................... 84

© 2011 Devolutions inc.
Getting started
Getting started

1.1 What is Remote Desktop Manager?

Description

Remote Desktop Manager is an application designed to manage all of your remote connections and virtual machines. With Remote Desktop Manager, you can quickly and easily add, edit, delete, share, organize and find your remote connections.

Remote Desktop Manager acts like a wrapper and a manager around existing technologies, and uses no proprietary protocols. All communications are established using either an external library or third party software.

Remote Desktop Manager is compatible with many tools and technologies, including: Citrix, Dameware, FTP, Hyper-V, LogMeIn, Microsoft Remote Assistance, Microsoft Remote Desktop, PC Anywhere, Radmin, SSH, Sun Virtual Box, Team Viewer, Telnet, Terminal Services, Virtual PC, VMware, VNC, X Windows, and more!

Where Do I Start if I Don’t Know Anything About Remote Connection Technologies?

If you’ve never used Remote Desktop Client (mstsc.exe), VNC or any other communication application or tool, and you simply want to connect to a remote machine, we recommend that you use LogMeIn, which is a free web-based remote access application.

Remote Desktop Manager Supports the Following Protocols

- FTP (File Transfer Protocol)
- HP RGS (HP Remote Graphics Software)
- HTTP/S (Hypertext Transfer Protocol)
- ICA (Independent Computing Architecture)
- RAW (Transmission Control Protocol)
- RDP (Remote Desktop)
- Rlogin (Rlogin)
- SSH (Secure Shell)
- Telnet (TELecommunication NETwork)
- VNC (Virtual Network Computing)
- And more!

1.2 System requirements

Minimum Requirements

- Windows 7, Windows XP (SP2 or later), Windows XP Embedded, Windows Vista, Window 2003 or Windows 2008
- Microsoft .NET Framework 3.5
- 800MHz processor
- 512MB RAM
- 1024 x 768 screen resolution
• 10+ MB hard drive space

64-bit Support

Remote Desktop Manager is compatible with all 64-bit versions of Windows, starting with Windows Vista SP1. However, it has not been tested on Windows XP 64-bit. Please use the app at your own risk.

Terminal Services and Thin Client Support

Remote Desktop Manager can be installed on a Terminal Server machine, and also on a thin client.

1.3 Creating a new session

Overview

The first thing you need to do prior to using Remote Desktop Manager is configure at least one session. There are many types of sessions, and you must be basically familiar with the session(s) that you plan on using. Remote Desktop Manager supports these types of session:

• Cisco VPN client
• Citrix XenApp (ICA)
• Dameware Mini Remote Control
• FTP (Explorer, Filezilla and WinSCP)
• LogMeIn
• Microsoft Hyper-V
• Microsoft Remote Assistance
• Microsoft Remote Desktop (RDP)
• Microsoft Virtual PC
• Microsoft Virtual Server
• Microsoft Windows Virtual PC
• Putty (SSH, Telnet, RAW and rLogin)
• Radmin Viewer
• SonicWall Global VPN client
• Sun VirtualBox
• Symantec PC Anywhere
• Team Viewer
• VMware ESXi
• VMware Player
• VMware vSphere
• VMware Workstation
• VNC (UltraVNC, TightVNC, RealVNC and embedded)
• XWindows
• And many more by installing other add-ons

Creating a Session from the Context Menu

The easiest way to create a new session is from the Context Menu. On the main application window, simply right-click Sessions and select Add from the menu. To initialize a new session, you can specify either the type of session, or a template. You will be prompted on the session property window to customize your settings. If you are unsure of the type of session you want, simply create a blank section and specify the session type at a later time.
Adding a new session

Creating a Session with Drag & Drop

You can also create a session by dragging & dropping an .rdp file in the main application window. When you do this, Remote Desktop Manager will ask you whether to import the content and create a new session, or create a session linked to the configuration file. It's also possible to drag & drop the LogMeIn desktop shortcut to create a LogMeIn session.

Please Note: Starting with Windows Vista, it's possible that drag & drop does may not work because of the OS's new security settings, which prevent an application from running in a different context. For example, if Remote Desktop Manager is running in administrator mode and Internet Explorer is running in default mode, Windows will not allow you to drag a url link in the application.

Creating a Session by Importing its Configuration

You can also import a session by using the Import Computer Wizard, or by importing its configuration directly from one any compatible applications supported by our importing tools. Please learn more about this here.
1.4 Configuring a session

Description

Each session type has its own specific settings. However, some common settings are shared.

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the session that appears in the sessions list. By default, this is the host used for the remote connection.</td>
</tr>
<tr>
<td>Group / folder</td>
<td>This is used to organize the session in different folders, either in the context menu or in the tree view. Learn more here.</td>
</tr>
<tr>
<td>Display</td>
<td>Allows the session to be opened and embedded in Remote Desktop Manager, or externally. If the application allows and if opened externally, it also allows choice of monitor.</td>
</tr>
<tr>
<td>Security Group</td>
<td>In the Enterprise edition, allows the Administrator to assign a security group to a session, and permit a subset of selected users to see this session.</td>
</tr>
<tr>
<td>Credentials</td>
<td>Used to define the credential source via the following:</td>
</tr>
<tr>
<td></td>
<td>• Session-specific credentials: uses the username and password from the session type configuration.</td>
</tr>
<tr>
<td></td>
<td>• Credential repository: links this session to an existing credential repository entry.</td>
</tr>
<tr>
<td></td>
<td>• Embedded credential entry: creates an embedded credential repository entry. This is useful when integrating LastPass, KeePass or any other</td>
</tr>
<tr>
<td>Tab Page</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>More tap page</td>
<td>Contains the alternate host configuration, the session description, and the keyword entries. The session description can be in plain text, in rich text format, or a website link.</td>
</tr>
<tr>
<td>VPN tab page</td>
<td>Used to command an optional VPN connection to open before the main session is opened.</td>
</tr>
<tr>
<td>Sub connection tab page</td>
<td>Contains a sub-connection linked to the main session. It's possible to share some variables, such as the host name, which is useful for connecting to the same host with a different protocol. For example, the main session can be a RDP session, and a sub-connection can be configured to access different share folders on the machine or an FTP site.</td>
</tr>
<tr>
<td>Information tab page</td>
<td>Contains different types of information related to the session, such as the machine specifications or some useful notes. Custom information can also be added.</td>
</tr>
<tr>
<td>Events tab page</td>
<td>Contains a script or a command line to be executed before or after establishing a connection. For example, this can be used to execute a batch file or an external application that prompts the user for more information, or to update a log on an external server.</td>
</tr>
<tr>
<td>Logs tab page</td>
<td>Contains the session logs and other related options. For example, entering a note can be made mandatory, and a warning message can be shown when when a user is already logged onto the machine.</td>
</tr>
<tr>
<td>Attachment tab page</td>
<td>Manages the session attachments, and used to add, edit and delete the linked files.</td>
</tr>
<tr>
<td>Tools tab page</td>
<td>Contains all of the settings related to the session tools (e.g. Services, Wake On Lan, Shutdown Remote Computer, etc.) available in the application. It's possible to assign a different set of credentials to execute the tools.</td>
</tr>
<tr>
<td>Advanced tab page</td>
<td>Contains more advanced settings related to the session, such as the internal data source ID and session ID. These values can be used to invoke Remote Desktop Manager on a command line to open the session, or to run a batch modification.</td>
</tr>
</tbody>
</table>

### 1.5 Connecting to a session

**Description**

There are two possible connection modes for opening a session:

- From a configured session in the data source
- With quick connect

Depending of the mode, Remote Desktop Manager can use a completely different application or library. For example, the external mode for Remote Desktop will use the Microsoft Remote Desktop's client (mstsc.exe), and the embedded mode will use the ActiveX.

**Configured Session**

You may open a session by double clicking it in the sessions list, or by using the context menu. The session will use the default settings when double clicked. Use the context menu to specify further...
options.

Via the menus, you may specify different connection options, such as:

- Full screen
- Embedded / External mode (click [here](#) for more details)
- Console or admin mode with the RDP protocol
- Force prompt for credentials
- Open with or without the configured VPN
- Open from a template

Opening an existing session

**Quick Connect**

Learn more about quick connect [here](#).

### 1.6 Embedded / tabbed mode vs external mode

**Description**

Remote Desktop Manager provides two types of session:

- External
- Embedded/tabbed

Please note that some sessions will not support both modes. It depends on the integration and the availability of the third party application.

**External Mode**

External mode session are opened as an external process, with no direct link to Remote Desktop Manager.

This mode usually launches the native application. For example, the native application for RDP is mstsc. exe. Typically, it's also possible to choose the destination monitor. Also, depending on the type of session, an external mode session view will be updated if Remote Desktop Manager can detect that its running.
Embedded/Tabbed Mode

An embedded session runs within the confines of the Remote Desktop Manager window, and displays tabs at the top of the window. This mode centralizes the opened session in the application, which makes it easy to switch from one to another.

There are several session-specific actions available by right clicking (Context Menu) on the title of the tab.

You can also show the session footer (description, information, log, attachment and details) at the bottom of the screen, and capture a screenshot of the content.
Embedded/Tabbed Mode - Undocked

While the embedded mode is useful in some cases, you may prefer to move the content in an external window. If so, this can be easily done using the context menu. Remote Desktop Manager will create a new window to contain the tabbed session, and will allow you to move it anywhere else (i.e. on another screen).

To dock the content back to its original place, use the context menu by right clicking on the window icon.
1.7 Group / folder management

Description

Groups or folders are used to organize your sessions in a logical way. It's possible to create groups and sub groups, which Remote Desktop Manager will automatically sort alphabetically.

Groups can be created in two different ways:

- Via the session properties
- From the session tree view

Creating Groups via the Session Properties

Groups can be specified in the session properties. Simply fill this field with your desired group name, and Remote Desktop Manager will generate the corresponding tree structure. Use the backslash (\) to create a sub group.

For example, "Office\Canada\Montreal" will create three nodes in the tree:
Creating Groups from the Tree View

By right clicking the root node of a group or an existing session, a context menu appears allowing you to create a new group.

The "Add Group" dialog box will then prompt you to enter the name of the group, and choose its parent group.
Once a group is created, you can add a session by using the menu, or by dragging its node directly to the content of the group.
2 Views

2.1 All sessions view

Description

This is the default view, and lists all existing sessions. The visual structure can be a list or tree view.

<table>
<thead>
<tr>
<th>View</th>
<th>Tools</th>
<th>Window</th>
<th>Help</th>
<th>192.168.0.100</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Sessions</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Opened Sessions</td>
<td>F8</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Most Recent Sessions</td>
<td>F9</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Favorite Sessions</td>
<td>F10</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>View Credential Entries...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>View Session Script Tools...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>View VPN Entries...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Filter...</td>
<td>Alt+Shift+F</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Available session views

The list can contain a large number of session configurations. Use the filter box at the bottom of the screen to help you find what you need. Learn more about this feature [here](#).

Tree View

The tree view offers the most flexible display mode.
Tree view

List View

The list view displays the sessions as icons, titles or details.

2.2 Opened view

Description

The opened view shows currently opened sessions by type, and for the local machine only. You can focus and bring to front/close an opened session by double clicking it from the list. All of the embedded sessions are listed, and the external session will appear if Remote Desktop Manager is able to discover the specific type of session.

Local Opened Sessions
Local opened session view

**Notes**

- Remote Desktop Manager tries to detect opened sessions even if they weren't launched from the application. It uses the name of the process to accomplish this task.
- VPN sessions do not appear in the list.

**Global Opened Sessions**

With the SQL Server and Online data source, you can monitor currently running sessions, provided that they have been opened within Remote Desktop Manager.

Global opened session view

For many reasons beyond our control, it's possible for a session to be terminated without Remote Desktop Manager knowing that this has taken place. This can happen, for example, if Remote Desktop Manager isn't running when another application ends. As a result, any terminated session will remain listed in the log. You may manually mark it as closed via the contextual menu.

To review a detailed log, double click on a session entry.
2.3 Favorites

Description

This view contains all of your favorite sessions that have been configured in the current data source.

There are two types of favorite sessions:

- **Shared favorites**
- **Local favorites**

Shared favorites are shared by all users who are connected to the data source, and are directly configured from the session.

Local favorites are flagged locally on the current machine by the current user. The settings are saved in the application settings.

**Adding a Session to the Shared Favorites**

You may add or remove a session from the shared favorites by editing its properties.
You can also use the context menu to include or remove a session from your favorites. To do this, right click on the session.

**Adding a Session to the Local Favorites**

The local favorites or user favorites can be added through the session's context menu.

2.4 **Most recently used**

**Description**

This view show the most recently used sessions for a specific data source on the local computer.
2.5  **Application tools**

**Description**

This view shows all pre-configured tools. These tools are not specific to a session, and each is executed on the local computer. For specific session tools, see the session tools available in the context menu.
Available Tools

- Command Prompt
- Computer Management
- Control Panel
- Event Viewer
- Internet Information Services (IIS) Manager
- IP Config
- Open Network Connections
- Registry Editor
- Services

Application Tools Add-Ons

You may add more application tools by using the SDK. These tools will be loaded when Remote Desktop Manager starts.
Part

Data source types
3 Data source types

3.1 Overview

Description

All sessions are saved in a data source. Remote Desktop Manager supports multiple types of data source. To start, decide which data source you’ll be using. If you’re running the Standard edition, you’ll be running from the local data source (which is an Access database by default).

There is no limit for the Enterprise edition, but a Microsoft Access data source is also created to save local sessions.

Data source options

Data Source Types

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Pros and cons</th>
</tr>
</thead>
</table>
| Amazon S3 storage     | Remote Desktop Manager saves the settings in a file located in an Amazon S3 bucket. Amazon S3 is a storage service for the Internet. It's designed to make web-scale computing easier for everyone. | Pros:  
  • Can be shared in read-only mode  
  • Backups (by Amazon) are automatic  

Cons:  
  • You must have an Amazon account and pay storage fees  
  • No security management |
<table>
<thead>
<tr>
<th>Data source types</th>
<th>Amazon S3 provides a simple web services interface that can be used to store and retrieve any amount of data, at any time, from anywhere on the web, and Remote Desktop Manager use its API to persist your session settings. More details on cloud computing and Amazon S3 can be found at: <a href="http://aws.amazon.com/s3/">http://aws.amazon.com/s3/</a></th>
<th>• There is a possibility for conflict or data corruption to occur • Doesn't support all features, such as attachments, connection logs and security access</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dropbox</td>
<td>Remote Desktop Manager uses the Dropbox API to retrieve the XML file from the configured repository.</td>
<td>Pros: • Can be shared in read-only mode • Backups (by Dropbox) are automatic • Storage infrastructure is free Cons: • No security management • There is a possibility for conflict or data corruption to occur • Doesn't support all features, such as attachments, connection logs and security access</td>
</tr>
<tr>
<td>FTP</td>
<td>Remote Desktop Manager uses an FTP connection to retrieve the XML file.</td>
<td>Pros: • Can be shared in read-only mode • Easy to deploy online Cons: • No security management • There is a possibility for conflict or data corruption to occur • Doesn't support all features, such as attachments, connection logs and security access</td>
</tr>
<tr>
<td>Microsoft Access</td>
<td>Remote Desktop Manager saves the settings in a Microsoft Access database on the local machine, or on a network share. Microsoft Access is a pseudo relational database management system from Microsoft, which combines the relational Microsoft Jet Database Engine with a graphical user interface and software development tools.</td>
<td>Pros: • Easy setup • Can be shared • Easy backup Cons: • Slower than SQL Server • No security management • There is a possibility for conflict or data corruption to occur • Doesn't support all features, such as attachments, connection logs and security access</td>
</tr>
<tr>
<td>Microsoft SQL Server</td>
<td>Remote Desktop Manager uses the power of SQL Server to save and manage all sessions. This is the recommended data source for a multi-user environment. <strong>Note:</strong> SQL Server 2000 is not supported.</td>
<td>Pros: • Quick • Reliable • Secure • Supports all features, such as attachments, connection log, offline</td>
</tr>
</tbody>
</table>
| Remote Desktop Manager Online | Remote Desktop Manager uses a mySQL database to store session information. | Pros:  
- Quick  
- Reliable  
- The database is free and can be installed on Linux  
- SQL Server Express is free  
Cons:  
- No security management  
- Doesn't support all features, such as attachments, connection logs and security access |
| XML file storage | Remote Desktop Manager saves the settings directly in a file with the XML format. | Pros:  
- Easy backup  
- Can be edited manually or by an external system  
- Nothing to install  
Cons:  
- No possibility of sharing  
- No security management  
- There is a possibility for conflict or data corruption to occur  
- Doesn't support all features, such as attachments, connection logs and security access |
| Web | Remote Desktop Manager uses a Web connection to retrieve the XML file. | Pros:  
- Easy backup  
- Can be edited manually or by an external system  
- Nothing to install  
Cons:  
- No possibility for sharing  
- Read-only  
- Doesn't support all features, such as offline mode and security management |

© 2011 Devolutions inc.
Multiple Data Sources

In the Enterprise edition, you can configure multiple data sources within the application. These data sources can mixed, but there can only be one active data source at a time.

It's also possible to switch from one data source to another via the data source combo box. You may assign a default data source in the data source dialog. The default data source will be open when Remote Desktop Manager starts.

3.2 Managing a data source

Import/Export Data Source

You can simplify deployment for multiple users by importing or exporting the data source. The generated file will have an .rdd extension. Remote Desktop Manager allows you to export the online data source settings directly to an .rdd file. So do this, simply open the data source dialog (File->Data Sources...) to import or export the file.

Also, a locked data source can be exported and imported, but its content will not be accessible unless a password is entered. See below for more information.

Lock Data Source

To protect sensitive data in your data source configuration (e.g. server URL or credentials), you may wish to lock the data source before you install it for you users. You can do this by using the Lock/Unlock button from the toolbar.
The locked data source will require a password. The password must be set when the lock is applied.

**Please note:** There is NO way of unlocking the data source if the password is lost or forgotten. In such an event, you will need to configure a new data source.

**Data Source Settings**

With SQL Server and Remote Desktop Manager Online, you can set different data source settings. These settings help ensure that the application is secure. These settings are available via **File -> Administration -> Data Source Settings**
Data source types

Security Provider

The security provider is responsible for encrypting the data in the database. It’s available with SQL Server and Remote Desktop Manager Online only.

Select the provider you wish, and configure it by using the menu File->Administration->Security Provider...

Please note that changing a security provider when many sessions have previously been configured may take a bit of time. We advise you to create a backup prior to doing this.
### Security Provider

<table>
<thead>
<tr>
<th>Security Provider</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The session data is not encrypted at all.</td>
</tr>
<tr>
<td>Basic</td>
<td>All of the data is encrypted in the database, and it's impossible for an external system to access it.</td>
</tr>
<tr>
<td>Default</td>
<td>This is the legacy security provider. The data is encrypted if the session configuration is set accordingly in the advanced settings.</td>
</tr>
<tr>
<td>Shared passphrase</td>
<td>All of the data is encrypted with a mix of our key, a salt and the passphrase. This is the most secure encryption, but if the passphrase is lost, there is nothing that can be done to recover the data.</td>
</tr>
</tbody>
</table>

By using your own passphrase with Remote Desktop Manager Online, you ensure that nobody can read your session, even if people have direct access to your database(s).

**Note**: Regardless of the security provider you select, the password is encrypted at least once in the database. There is no password stored in clear text at any time.

### 3.3 Amazon S3

**Description**

Remote Desktop Manager saves the settings in a file located in an Amazon S3 bucket.

Amazon S3 is storage for the Internet. It is designed to make web-scale computing easier for everyone.

Amazon S3 provides a simple web services interface that can be used to store and retrieve any amount of data, at any time, from anywhere on the web and Remote Desktop Manager uses this API to persist your session settings.

More details on cloud computing and Amazon S3 can be found at: [http://aws.amazon.com/s3/](http://aws.amazon.com/s3/)
## Highlights

- This data source can be shared over the Internet between multiple users
- No conflict management
- This is a file-based data source, based on the XML data source
- To avoid data corruption, the session list should be modified by one user at a time

### 3.4 Dropbox

**Description**

Remote Desktop Manager uses the Dropbox API to retrieve the XML file from the configured repository. There is no need to install the Dropbox client on the machine to open the data source. It is also possible to configure more than one Dropbox account on the same machine.
Remote Desktop Manager (Version 6.0)

Dropbox setting dialog

**Highlights**

- This data source can be shared over the Internet between multiple users
- No conflict management
- The data source supports auto refresh
- This is a file-based data source, based on the XML data source
- To avoid data corruption, the session list should be modified by one user at a time

3.5 **FTP**

**Description**

Remote Desktop Manager downloads and uploads the session settings directly from file located on an FTP site.
### Highlights

- This data source can be shared over the Internet between multiple users
- No conflict management
- This is a file-based data source, based on the XML data source
- To avoid data corruption, the session list should be modified by one user at a time

### 3.6 Microsoft Access

#### Description

Remote Desktop Manager saves the settings in a Microsoft Access database, located on the local machine or on a network share.

Microsoft Access is a pseudo relational database management system from Microsoft, which combines the relational Microsoft Jet Database Engine with a graphical user interface and software development tools.
Highlights

- This data source supports the native Access database password (Note that the password must be set using Microsoft Access directly -- Remote Desktop Manager does not allow you to set or change the database, because it require an exclusive connection to it)
- The offline mode is supported by this data source
- The database can be shared by multiple users on a network drive, but the performance and the data integrity can't be guaranteed

3.7 Microsoft SQL Server

Description

Remote Desktop Manager uses the power of SQL Server to save and manage all sessions. This is the recommended data source type for a multi-user environment.

Note: SQL Server 2000 is not supported.
Data source types

SQL Server setting dialog

Highlights

- This data source allows user management with a superior security model
- The offline mode can be used when the server is unavailable, or when the user is on the road
- Full connection log and attachments support
- The data source supports an auto refresh at specific interval
- Microsoft SQL Azure can be used to create an online database. Get more detail on SQL Azure [here](#)

3.8 **mySQL**

**Description**

Remote Desktop Manager uses a MySQL database to store the session data. The MySQL data source is an add-on. It must be installed separately, and is only supported in the Enterprise edition.
Highlights

- The data can be shared on a MySQL database installed on either Windows or Linux

3.9 Remote Desktop Manager Online

Description

Remote Desktop Manager Online is a hosted repository managed by Devolutions. The Remote Desktop Manager client connects directly to the data source. More details are here.
Remote Desktop Manager Online setting dialog

**Highlights**

- No VPN required to access the data
- Full connection logs
- Hosted on Microsoft Windows Azure and Microsoft SQL Azure
- This data source allows user management with security groups
- The offline mode can be used when the server is unavailable, or when the user is on the road

**3.10 Web**

**Description**

Remote Desktop Manager reads the session settings directly from a file located on a web site.
Highlights

- This read-only data source can be shared over the Internet between multiple users
- This is a file-based data source, based on the XML data source
- Supports Windows authentication in IIS

3.11 Xml

Description

Remote Desktop Manager saves the settings directly in a file with the XML format.
### XML setting dialog

#### Highlights

- This is a very simple data source and it can be modified or generated by an external tool
- It's possible to configure auto refresh and share the file on a network share
- There is no locking mechanism – therefore only one user at the time should modify the list
- This is a good replacement for the Access data source, or for users who have problems with their MDAC driver (Microsoft Access database connector)
Connection types
4 Connection types

4.1 Overview

Description

Remote Desktop Manager separates its connection types in three different categories:

- Remote connections
- Virtualization
- Others

Remote Connections

This category contains all of the connection types that are used to connect to a remote system, including computers, switches, VPNs or printers.

Virtualization

This category contains all of the virtualization connections, including the local virtual machines tools and server tools. Remote Desktop Manager supports tools from Microsoft, VMware and Sun Microsystems.

Other

This category contains many useful session types that are not directly supported, or those that are are neither a virtualization nor a remote connection.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command Line</td>
<td>Used to execute an application that is not supported in Remote Desktop Manager. It can also be used to execute a Powershell script or a batch file.</td>
</tr>
<tr>
<td>Text</td>
<td>Used to add specific information to a group of session. It contains a rich text format that can be associated to a group of sessions.</td>
</tr>
<tr>
<td>Windows Explorer</td>
<td>Used to create a shortcut to a local folder or a network folder (can be embedded/not embedded).</td>
</tr>
</tbody>
</table>

4.2 Citrix (ICA / HDX)

Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
</tbody>
</table>
4.3 Command Line

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td>Any application</td>
</tr>
</tbody>
</table>

4.4 Dameware Mini Remote Control

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
</tbody>
</table>

4.5 Ftp

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>Filezilla only</td>
</tr>
</tbody>
</table>
### 4.6 HP RGS

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td>X</td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td>X</td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td>X</td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td>X</td>
</tr>
</tbody>
</table>

- Windows Explorer
- Filezilla
- WinSCP

### 4.7 LogMeIn

**Description**

LogMeIn remote access products use a proprietary remote desktop protocol that is transmitted via SSL. An SSL certificate is created for each remote desktop, and is used to cryptographically secure communications between the remote desktop and the accessing computer.

Users access remote desktops using an Internet-based web portal and, optionally, the LogMeIn Ignition stand-alone application. The portal also provides status information for the remote computers and, optionally, remote computer management functions.

You can find more information [here](#).

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>Embedded only</td>
</tr>
</tbody>
</table>
Remote Desktop Manager (Version 6.0)

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td>Google Chrome, Internet Explorer, Firefox</td>
</tr>
</tbody>
</table>

**Add a LogMeIn Computer**

1. Create a LogMeIn account
2. Add your computer to LogMeIn
3. Edit the computer settings in LogMeIn
4. Select the tab "Desktop Shortcut"
5. Drag and drop the computer icon in Remote Desktop Manager

**4.8 Microsoft Remote Desktop (RDP)**

**Specifications**

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td>X</td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td>• Credentials</td>
</tr>
<tr>
<td></td>
<td>• Resolution</td>
</tr>
<tr>
<td></td>
<td>• Screen size</td>
</tr>
</tbody>
</table>
### 4.9 Microsoft Remote Assistance

#### Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td></td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td></td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td>mstsc.exe</td>
</tr>
</tbody>
</table>

### 4.10 pcAnywhere

#### Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td></td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td></td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td></td>
</tr>
</tbody>
</table>

### 4.11 Radmin

#### Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td></td>
</tr>
</tbody>
</table>
Remote Desktop Manager (Version 6.0)

<table>
<thead>
<tr>
<th>Show opened session</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td></td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td></td>
</tr>
</tbody>
</table>

4.12 TeamViewer

Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td></td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td></td>
</tr>
</tbody>
</table>

4.13 Telnet / SSL / rLogin / RAW

Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td>Putty.exe/PLink.exe</td>
</tr>
</tbody>
</table>

4.14 VNC

Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
</table>
4.15 Virtualization

Description

Supported virtualization applications include:

- Microsoft Hyper-V
- Microsoft Virtual PC
- Microsoft Virtual Server
- Microsoft Windows Virtual PC
- Oracle VirtualBox
- VMware ESXi
- VMware Player
- VMware Workstation
- VMware vSphere

4.16 Web

Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td>X</td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td>X</td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td>X</td>
</tr>
<tr>
<td>Supported applications</td>
<td>RealVNC</td>
</tr>
<tr>
<td></td>
<td>TightVNC</td>
</tr>
<tr>
<td></td>
<td>UltraVNC</td>
</tr>
<tr>
<td>Google Chrome, Internet Explorer, Firefox</td>
<td></td>
</tr>
</tbody>
</table>
## 4.17 X Windows

### Specifications

<table>
<thead>
<tr>
<th>Features</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>External mode</td>
<td>X</td>
</tr>
<tr>
<td>Embedded mode</td>
<td></td>
</tr>
<tr>
<td>Show opened session</td>
<td>X</td>
</tr>
<tr>
<td>Batch edit</td>
<td></td>
</tr>
<tr>
<td>User settings can be overridden</td>
<td></td>
</tr>
<tr>
<td>Auto login</td>
<td></td>
</tr>
<tr>
<td>Full screen</td>
<td></td>
</tr>
<tr>
<td>Multi-monitor support</td>
<td></td>
</tr>
<tr>
<td>Supported applications</td>
<td>xlaunch</td>
</tr>
</tbody>
</table>
Common features
5 Common features

5.1 Advanced description

Description

Remote Desktop Manager supports three description types:

- Plain text description
- RTF description
- External URL description.

The description is displayed in **bold** on the dashboard.

Plain Text Description (Basic)

This is the most basic description, and is simply a text without formatting.

Plain text description

RTF Description (Advanced)

The RTF (Rich Text Format) description offers more formatting options, and allows you to change:

- Text color
- Font size
- Font style
- Text alignment

You can also create lists (numbered and bullets).
Remote Desktop Manager will display the description exactly the way it was formatted in the editor.

**External URL Description (Advanced)**

The description may also be a link to a website (e.g. on a server in the Intranet). By using session variables (\$SESSION_ID\$, \$SESSION_NAME\$, etc.), the website can be generated on-the-fly as an HTML page, and its URL returned. This lets you integrate an external system or a custom application.

5.2 **Command line arguments**

**Usage**

Remote Desktop Manager can be executed in a command line. However, some features are only available in the Enterprise edition.
usage: RemoteDesktopManager.exe [parameters]

/Silent
Execute the application minimized in a system tray icon. This option cannot be combined with other parameters.

/Datasource:{datasource id}
Specify the data source id (available in the Advanced Tab of the session)

/Session:{session id};{session id}
Specify one or more session IDs (available in the Advanced Tab of the session)

/ChangePassword:{new password}
Change the session password. Only available for Remote Desktop sessions and embedded passwords. The data source ID and the session ID are required.

/RegisterUser:"{registration user}"  
Change the Remote Desktop Manager username. The value must be in double quotes.

/RegisterSerial:"{serial number}"  
Change the Remote Desktop Manager serial number. The value must be in double quotes.

5.3 Connection details

Description
The connection details can be found on the dashboard, and is a simple grid that lists complete session information. The grid supports the copy/paste feature. Exporting is not available.
5.4 Dashboard

Description

The dashboard displays a quick view showing possible actions, or information for the current session or group. It contains the same actions that are found in the context menu.

5.5 Options dialog

Description

Remote Desktop Manager contains many option pages such as:

- UI options
- Start/close options
- Quick connect
- Search filters
- Tray icon/taskbar setting
- Installation/default path
- Templates
- Security settings
5.6 Keyboard shortcuts

**Open Session**

*Enter*: Open session

*Ctrl+Enter*: Open session (tabbed) or external

*Shift+Enter*: Open session in console/admin mode

*Alt+Enter*: Open session in full screen

**Edit Session**

*Ctrl+N*: Add a new session

*Ctrl+D*: Create a copy of the current session

*Ctrl+Del*: Delete the selected sessions

*F2*: Rename the session or the group

**View**

*F3*: Show the session list (tile view)

*F4*: Show the session list (list view)

*F5*: Refresh the current list

*F6*: Show the session list (large icon)

*F7*: Show the session list (tree view)

*F8*: Show the opened session view

*F9*: Show the most recently used view

*F10*: Show the favorite sessions view

*F11*: Show the local connections log

*F12*: Show the session list (detail view)

*Ctrl+F4*: Close the current tab page

*Alt+F6*: Hide / show the header panel

*Alt+F7*: Hide / show the footer panel

*Alt+F8*: Hide / show the session panel
Alt+F9: Hide / show the tabbed panel

**Import/Export**

Ctrl+Shift+I: Import session (.VNC, .RDP, .RDM)

Ctrl+Alt+E: Export session (.RDM)

Ctrl+Alt+Shift+E: Export session with Credentials (.RDM)

Ctrl+Shift+E: Export session as Remote Desktop (.RDP)

**Miscellaneous**

F1: View online help (http://help.remotedesktopmanager.com/)

Ctrl+A: Open an ad hoc Remote Desktop connection

### 5.7 Quick connect

**Description**

Via the quick connect button, you can open a session *ad-hoc* by specifying destination and session type. It's also possible to create a template and use it for the quick connect. You can specify the desired default settings, and Remote Desktop Manager will merge them with the specified host.

![Quick connect - connection type selection](image)

The $QUICK_CONNECT$ variable can be used in a template to specify the item to insert. It will assigned at runtime with the content of the combo box.

![Quick connect](image)

### 5.8 Search / filter

**Description**
It's also possible to apply a filter by typing some characters in the filter box. The filter is applied using the specified settings in the application's options. It's possible to include the following in the filter:

- Session name
- Group name
- Description
- Keywords
- Host
- Favorites
- Session types (credentials, script tools, VPN, etc.)

If the session view is hidden, a dialog will appear with the filtered content.

### 5.9 Security

#### Description

All passwords stored in the application database, and are encrypted using a strong encryption algorithm. As such, even if a user accesses the data directly in the database, it will be unreadable.

If you choose to store passwords locally, Remote Desktop Manager will use the same mechanism used by mstsc.exe (Microsoft Remote Desktop client), and the passwords will be stored in the Window Credential repository. You can access it from "User Account" in Windows. However, note that you will be unable to see the password because it has been encrypted by Windows.

**What is the Windows Credential Manager?**

The Windows Credential Manager allows you to store credentials, such as user names and passwords, which you use to log on to websites or other computers on a network. By storing your credentials, Windows can automatically log you on to websites or other computers. Credentials are saved in special folders on your computer called vaults. Windows and other programs (such as web browsers) can securely give the credentials in these vaults to other computers and websites. For information about saving credentials in a vault, see store passwords, certificates, and other credentials for automatic
logon. You can also learn more about Windows Credential Manager [here](#).

**Tips**

It's also possible to enforce the security by:

- Using SQL Server and give restricted user access
- Enabling the encryption of the session in the Advanced tab page (Encrypt configuration in the data source)
- Choosing not to save password in the SQL Server database, which will prompt for the credential on the first connection
- Using the database settings
- Using the security provider with a passphrase

### 5.10 Session tools

**Description**

Session tools are available in the session context menu (Session Tools), and also in the dashboard. There are three types of tools:

- Built in tools
- Add-on session tools
- Session script tools
Session Tools

- Computer Management
- Event Viewer
- Services
- Server - Home Page
- Server - Remote Management (iLO)
- Terminal Sessions
- Wake On Lan
- Continuous Ping
- Ping
- Trace Route
- Shutdown / Restart Computer
- Who Is
- IP config
- ipconfig /all
- notepad
- Remote Command Prompt

Session tools

Built-in Tools

These tools are implemented directly in Remote Desktop Manager, and are available without any installation or special configuration.

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer Management</td>
<td>Opens the Computer Management snap-in for a remote machine.</td>
</tr>
<tr>
<td>Event Viewer</td>
<td>Opens the Event Viewer for a remote machine.</td>
</tr>
<tr>
<td>Services</td>
<td>Opens the Windows Services manager for a remote machine.</td>
</tr>
<tr>
<td>Server - Home Page</td>
<td>Opens a web page if a home page is configured in the Information tab of the session configuration.</td>
</tr>
<tr>
<td>Server - Remote Management</td>
<td>Opens a web page, if a remote management link (e.g. iLo) is configured in the Information Tab of the session configuration.</td>
</tr>
<tr>
<td>Terminal Sessions</td>
<td>Opens the Remote Desktop Manager Terminal Services dashboard for the selected session, so that you can:</td>
</tr>
<tr>
<td></td>
<td>• View opened sessions</td>
</tr>
<tr>
<td></td>
<td>• View the running processes</td>
</tr>
<tr>
<td></td>
<td>• Send a message</td>
</tr>
<tr>
<td></td>
<td>• Restart the machine</td>
</tr>
<tr>
<td></td>
<td>• Logoff the selected user</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Wake On Lan</td>
<td>Sends a command for the Wake on Lan. For more details, see this <a href="#">section</a>.</td>
</tr>
<tr>
<td>Continuous Ping / Ping / Trace Route</td>
<td>Opens the ping/trace manager of Remote Desktop Manager and returns the result.</td>
</tr>
</tbody>
</table>

### Add-on Session Tool

You can extend the built-in list using the SDK and installing the compiled add-on. The new tools will be displayed below the built-in tool list in the menu and the dashboard. By creating your own add-ons, you gain more control on the implementation including execution, configuration and monitoring.

You can use the Add-on Manager, or download them directly from our [web site](#).

### Session Script Tools

The session script tool can be a script, a command line, or an helper applicable to a selected session. They can be configured and shared in the data source. They are listed in the dashboard under the session tool section. For more information, see this [section](#).

### 5.11 Session variables

#### Description

Session variables can be used in any session configuration, or with any templates. They will be replaced by their corresponding values just prior to a connection. They provide greater value when used with a session related to a parent (sub connection). You can select a variable by double clicking it directly in the dialog. Please note that variables are both case-sensitive and UPPERCASE.
Session variable dialog

Tip: Use the custom field in your variables to pass any other parameters.

**Special Variables**

$PASSWORD$: For security reason, this is only available with the command line session type.

$QUICK_CONNECT$: This variable is used as a placeholder for the quick connect combo box value.

### 5.12 System Tray icon

**Description**

Remote Desktop Manager also lets you show the session list and other useful information in the Windows system tray. You can also customize the content. To open a session, click on it or use the context menu by right-clicking on the icon to access more options.
The application's options window contains many settings that enable you to customize the system tray icon settings. You can also disable it from here, or change its default behavior.

**System Tray Icon Section**

<table>
<thead>
<tr>
<th>Section name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session List</td>
<td>Shows the sessions from the current data source. Sessions are listed by default, you it's also possible to include only those who are marked as favorites.</td>
</tr>
<tr>
<td>Data Sources</td>
<td>Lists the available data source and allows the user to switch dynamically from one to another. This section only appears if it's enabled and more than one data source is configured.</td>
</tr>
<tr>
<td>Opened Sessions</td>
<td>Lists all the opened sessions exactly like the opened sessions view.</td>
</tr>
<tr>
<td>Tools</td>
<td>Lists all the configured tools like the configured tools view.</td>
</tr>
<tr>
<td>Quick Connect</td>
<td>Prompts for the quick connect dialog to open an add-hoc connection with a specific type or a selected template.</td>
</tr>
</tbody>
</table>

**5.13 Templates**

**Description**

This allows you to create predefined configuration available with the quick connect, or when you create or import a new session. There are two types of templates:

- Local template
- Shared template

Local templates are saved on the local computer, and are not available to other users. Shared templates are saved in the database, and can be used by more than one user. It's possible to define more than one template with the Enterprise edition.

Templates are available in the options dialog or via the menu **File > Templates**.
Usage

The template can be used to:

- Create a new session
- Quickly connect
- Open as a template
- Create an import wizard

5.14 VPN

Description

A VPN connection can be configured in the session properties. The connection can be established automatically, manually or when a particular condition is met. Simply select the desired mode in the Open combo box.

<table>
<thead>
<tr>
<th>Open mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always connect</td>
<td>Opens the VPN each time the session is launched.</td>
</tr>
<tr>
<td>Manual</td>
<td>The VPN is configured, but it must be opened manually from the session context menu or the dashboard.</td>
</tr>
<tr>
<td>Connect if unable to ping</td>
<td>The application will try to ping the host or a configured address. If unable to do so, the VPN will open before launching the session.</td>
</tr>
</tbody>
</table>

There are many supported VPN connection types, and many of them are available as a session type.
add-on. These include:

- Cisco VPN
- Microsoft VPN
- SonicWall VPN

You can also configure and link to another VPN session. Simply select the value **Existing Session** in the VPN type combo box and choose an existing session. The benefit of doing this is that you can share your VPN settings with multiple sessions, and manage them in one place.

The VPN's closing mode can also be configured:

<table>
<thead>
<tr>
<th>Close mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On session close</td>
<td>Closes the VPN as soon as it detects that the session is closed. However, some session types' close events cannot be detected, and as such the VPN must be closed manually.</td>
</tr>
<tr>
<td>Manually later</td>
<td>The VPN must be closed manually from either the session context menu or the dashboard.</td>
</tr>
<tr>
<td>Confirm disconnect</td>
<td>The application will try asking for a confirmation before closing the VPN when it detects that the current session is terminated.</td>
</tr>
</tbody>
</table>

Each VPN type has its own set of properties to configure, and you must know them in order to properly configure them.

![VPN session configuration](image)
Enterprise features
6 Enterprise features

6.1 Attachments

Description

With the Enterprise edition and the SQL Server data source, you can add an attachment to a data source. The file is stored in the database.

Attachment list

The attachment can be any type and any size, depending on your bandwidth and database. You can also view a saved attachment from: the session context menu, the session properties, or directly on the dashboard.

6.2 Batch edit

Description

Batch Edit is used to change the settings of multiple sessions in one operation. It can be used to remove or update all of the credentials of a group of sessions. This option can be found in the session context menu.
Batch edit context menus

You can also change:

- The username, the domain, and/or the stored password
- Some session-specific settings (e.g. the Remote Desktop settings)
- The security group assigned

**General Settings**

Via **Batch Edit -> Edit Sessions (General Settings)** from the context menu, you can change common session settings. The session can be of any type, because a common set of options are shared among sessions. The following general settings can be changed:

- Group
- Display
- Image
- Description
- Keywords
- Information (changed globally)
- VPN
- Events
- Log
- Tools
Credential Settings

You can change the configured credentials for multiple sessions in a batch. This is a good workaround for a feature not available in Remote Desktop Manager: inherited credentials. To change those values, use the context menu **Batch Edit-> Change Saved Credentials...**
Batch edit - credential settings

Also, you can clear existing credentials (Batch Edit-> Reset All Saved Credentials...) or passwords ( Batch Edit-> Reset All Saved Password...).

**Session Type Specific Settings**

Some settings are specific to the selected type of session. To change these values, use the context menu Batch Edit-> Edit Sessions (Session Type Settings)...

User-specific Settings

User-specific settings can be modified in a batch if they're supported by the type of session. To change user-specific sessions go to **Batch Edit-> Edit Sessions (User Settings)**...
**Security Group**

To apply a new security group to multiple sessions, use the menu **Batch Edit-> Edit Sessions (Security Group)**...
6.3 Connection events

Description

Remote Desktop Manager gives you the flexibility to run operations before or after establishing a connection within a session.

In the Events tab page of the session properties, simply set a script and/or a command line to be executed, and Remote Desktop Manager will execute the event at the appropriate time. You can also pass parameters, such as the session ID, the session name, or the configured username.

In addition, you can adjust the settings to run a script for an executable in a 64-bit context, or as an administrator. It's also possible to specify a timeout or pause a process currently running. This is sometimes necessary in order to allow the process to complete a task.

The only supported script file is a VBScript (.vbs).

6.4 Session log

Description

Remote Desktop Manager supports two types of logs:
- Local session log, which is file based
- Share session log, in a database

**Local Session Log**

A basic local logging system is automatically available by default. This allows the system administrator to view the log file for all session activities on the current machine. It’s available on the local machine only via the menu View Local Connection Log.

![Local connection log](image)

The log is written directly to a file in the settings folder.

**Shared Session Log**

The shared session log offers a more robust solution. Through it, it’s possible to monitor an opened session for all users by using the SQL Server, or the Remote Desktop Manager Online data source. The log is available for a specific session in the context menu View->Logs, in the session configuration (Log tab page), and in the dashboard.

The log contains all the CRUD (add, edit and delete) operations, including the time and the username. It also contains all the details about the open/closed sessions, including those from the VPN.
Session logs

It’s also possible to view in real time who is connected by ticking the checkbox “Show live session only.” This will filter the list to display only the opened sessions in the grid.

The session log can be visualized in a global view by using the shared connection log (View Shared Connection Log). Use this view to find information for multiple sessions for a specific time, or for a specific user. The window is similar to a search tool and it offers multiple filter types, including:

- User name
- Machine name
- Time period

6.5 Credential repository

Description

The credential repository is available in the Enterprise edition and allows you to set multiple sessions to a specific set of credential. This simplifies management by forcing users to modify their credentials in
one place. The list is visible in the tree view under the session list.

Currently, the credential repository is only available for the Remote Desktop connection type. You can also configure it to prompt you to select a set of credentials, which allows you to use multiple credentials for the same host.

To create an entry, use the session's context menu and select **Add > Credential Repository**.
There are multiple types of credentials, some of which require an external application. See the next section for more details.

**Credential Types**

Select one credential type provider to deliver data to the session or the VPN prior to establishing a connection.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>1Password</td>
<td>Use the credential from 1Password by creating an internal web server in Remote Desktop Manager to retrieve the information.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Default</td>
<td>Provide the username, domain and password to save the credential. This the default credential type.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Firefox Password Manager</td>
<td>Use the credential from Firefox by creating an internal web server in Remote Desktop Manager to retrieve the information.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Google Chrome Password Manager</td>
<td>Use the credential from Google Chrome by creating an internal web server in Remote Desktop Manager to retrieve the information.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>KeePass</td>
<td>Use a KeePass plugin to send the credential to Remote Desktop Manager. The KeePass application must be running, and the database must be opened. Learn more information here.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>LastPass</td>
<td>Use the credential from LastPass by creating an internal web server in Remote Desktop Manager to retrieve the information.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>Windows Credential Manager</td>
<td>Use an existing credential entry from the Windows Credential Manager (also called Windows vault).</td>
</tr>
</tbody>
</table>

**6.6 Import sessions**

**Import from a File**

Remote Desktop Manager can import sessions from different types of files:

- .vnc
- .rdp
- .rdm (Remote Desktop Manager native export format)

**Using the Import Wizard**

You can import your computers list from different sources. These sources include:

- Network neighborhood
• Your current domain or another domain on your network
• List of computers from a file

The wizard is available in the Enterprise edition, and can be found in the application menu File > Import Computer Wizard

Import computer dialog

**Importing from Another Application**

You can also import your sessions list from an existing application. Your configuration must not be encrypted, in order to allow Remote Desktop Manager to parse the content.

The list of the supported applications includes:

• RoyalTS ([http://www.code4ward.net/main/](http://www.code4ward.net/main/))
• mRemote ([http://www.mremote.org/wiki/](http://www.mremote.org/wiki/))
• Terminals ([http://terminals.codeplex.com/](http://terminals.codeplex.com/))
• Microsoft Remote Connection Manager ([download](http://microsoft.com))
• Boztech VNCScan (add-on)
• WinSCP (add-on)
• Filezilla (add-on)

This feature can be found in the application menu File > Import From Other Application
6.7 Offline mode

**Description**

The offline mode allows you to connect to a read-only copy of the data source when the live database is unavailable. It can be used when the VPN connection is down, or when a user is working from a disconnected network.

This feature is only available with the SQL Server data source, and it must be enabled in the settings. Remote Desktop Manager will automatically switch to offline mode when the application is unable to reach the data source.

You can also manually activate the offline mode by using the menu `File > Go Offline`. You can then reconnect to the live database when the connection is back online by using the menu `File > Go Online`.

6.8 Session script tools

**Description**

The session script tools can be either a script, a command line, or a helper applicable to a selected session. Each can be configured and shared in the data source, and are listed in the dashboard under the "Session script tools" section.

Session script tools are commonly used to retrieve an information, perform some action, change an item, or change a configuration on the session host. There are three types of tools currently supported:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Command line" /></td>
<td>Command line</td>
<td>Executes a basic command on the local machine.</td>
</tr>
<tr>
<td><img src="image" alt="PS Exec (PS Tools)" /></td>
<td>PS Exec (PS Tools)</td>
<td>A PS Exec command is sent to the remote machine. You can get more information from the Microsoft website <a href="link">here</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Template" /></td>
<td>Template</td>
<td>By configuring a template session script tool, it's possible to open a session with a completely different session type. The original parameters will be merged with the one from the specified template.</td>
</tr>
</tbody>
</table>
Note: The session variables can be used as parameters for the session script tools.

**Session Script Tools Manager**

The manager simplifies the installation of any session script tools provided by the community. You can import an existing tool directly in the current data source by clicking the Import button, and submit any interesting session script tools to us at support@devolutions.net.

**6.9 Sub connections**

**Description**

Sub connections are used to share properties between groups of sessions (e.g. the host name). They’re also used to regroup many connection types in one computer (e.g. the RDP/FTP/HTTP connection).

Sub connections are configured in the parent connection inside the **Sub Connections** tab page. Use the predefined variables in the child session to get access to the parent settings. The most common usage
is to reuse the host name from the parent within the sub connections.

6.10 User management

Description

With the SQL Server data source, you can create users and give them security access. By default, all SQL Server SYSDBA users are administrators. You must be administrator of the database (not Remote Desktop Manager) to create users and assign rights. The user/group administration is available from the menu in **File > Administration**, and only when a SQL Server data source is selected.

Security Groups are used to classify sessions and restrict access to certain users. There is no direct relationship between Active Directory and Security Groups. By default, every session is created without
security groups, and is visible to all connected users.

**Steps:**

1. Assign the security group to the session
2. Create the security groups
3. Create the required users
4. Link the security group to a user

**Notes:** All sessions without security groups are considered public.

**Creating Security Groups**

Security groups are created from the menu in **File > Administration**.

![Security group dialog](image)

**Assigning a Security Group to a Session**

Security groups can be assigned to sessions using the session's property window. Each session can only have one security group assigned.
Creating Required Users

If you wish, you can create a user linked to a domain. This dialog will create a login in SQL Server and a user in the current database. The login name is used to connect to the SQL Server, and the username is used to connect to the database. Typically, these have the same name.

If the connection already exists in the SQL Server database, the user will be created by using the existing password instead of the new one. You can assign different security options to a user, such as the offline mode, a read-only mode, and more. However, there is currently no way to inherit security rights from a group. They must be assigned individually for each user.

Linking a Security Group to a User
In the user editor, you can check or uncheck groups. A user with administrator rights has access to all of the configured sessions from all groups.

![User dialog - groups](image)

### 6.11 Wake-on-LAN

**Description**

Wake-on-LAN is an Ethernet computer networking standard, which allows a computer to be turned on or woken up by a network message.

Wake-on-LAN is supported in the Enterprise edition of Remote Desktop Manager. Plus, the destination motherboard must support it, and it must be enabled. The computer must also be in the local area network (LAN) and not connected in a VPN.

**Configure Remote Desktop Manager**

You must add a valid MAC address (Media Access Control address) in the session's configuration. The input field can be found in the **Information** tab and in the **Computer** child tab. The field name is MAC.
Session configuration - Wake-on-LAN

You can use the Discover button to automatically determine the MAC address. If this is unsuccessful, you will need to enter it manually.

Use Wake-on-LAN

If the settings are correctly configured, you can invoke the Wake-on-LAN from the session's context menu, which can be found in the Session Tools > Wake On Lan menu.
6.12 User specific settings

The "user specific setting" feature is only available for a SQL Server data source and for a Remote Desktop Manager Online data source.

It allows a user to replace the default session settings with his or her own values at the opening of the session. Several parameters can be changed, such as user name, password, and the default application.
Installation

Part VII
7 Installation

7.1 Client installation

Description

You can install Remote Desktop Manager by downloading the setup files or the binaries.

Setup

1. Execute the setup
2. Select the standard edition, or enter your user name and serial number
3. Configure your data source
4. Configure your installation path for all the external applications you plan to use. For example RealVNC, Putty, Filezilla, etc.

Binaries

1. Unzip the files in any folder and launch the executable
2. Select the standard edition or enter your user name and serial number
3. Configure your data source
4. Configure your installation path for all the external application that you plan to use. For example RealVNC, Putty, Filezilla, etc.

Terminal Services

Remote Desktop Manager can also be installed on a Terminal server, but to prevent loss of user settings, we recommend that you install the application in any folder except "Program Files" or "Program Files (x86)". The configuration and the default database will be created in this folder instead of the "Local Application Settings" folder.

7.2 Configuration file location

Default Location

Remote Desktop Manager saves its configurations in a file named remotedesktopmanager.cfg. This file contains all of the application settings and the configured data source. All of the data source settings are encrypted for security reason.

If Remote Desktop Manager is installed in a sub folder inside "Program Files" and is not running on a Terminal Server, the configuration is saved in "%LocalAppData%\Devolutions\RemoteDesktopManager."

If the application is running on a Terminal Server, the configuration is saved in "%AppData%\Devolutions\RemoteDesktopManager." It uses the roaming profile to avoid multi-user conflicts.

In any other case, the configuration is saved in the installation folder. This allows you to install multiple
versions of the application side-by-side, as long as you don't install it in a sub folder of "Program Files." (For more information on why -- this is because of the "Program Files" virtualization introduced with Windows Vista: http://support.microsoft.com/kb/927387.)

**Override the Default Path**

There are two possible ways to change the default option path:

1. Create a file named "Override.cfg" in the application folder. Remote Desktop Manager opens this file and reads the first line. It should contain the desired installation folder (without the option filename). If you wish to use the current installation path, put a dot in the file. Here are two examples:

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>c:\RDM</td>
<td>The config file is saved in a specific folder (RDM).</td>
</tr>
<tr>
<td>.</td>
<td>The dot is used to specify the Remote Desktop Manager installation folder.</td>
</tr>
<tr>
<td>%AppData%\Devolutions\RemoteDesktopManager</td>
<td>Specify the application roaming data folder.</td>
</tr>
</tbody>
</table>

2. By adding a key in the registry: CurrentUser\SOFTWARE\RemoteDesktopManager, OptionPath. Set the desired path in the key OptionPath. Don't forget to exclude the option file name in the key.

### 7.3 Portable (USB)

**Description**

Remote Desktop Manager can be used as a portable application. Here are some steps required to ensure that it runs correctly:

1. Unzip Remote Desktop Manager on the USB stick

2. Open Remote Desktop Manager and configure the data source relatively to the USB stick: . \Connections.mdb
Access data source saved on the USB stick

3. Configure your portable application (Filezilla, Putty, UltraVNC, etc.) in the same way (relative to the installation folder).
### 7.4 Registration

**Instructions**

After you receive our email, you can register the application and unlock the Enterprise features.

To register, go in the menu **Help > Register Version**.

Enter the user name and serial number exactly as noted in the email.
7.5 Uninstall

Instructions

Remote Desktop Manager doesn't install anything in the Windows directory, and the only registry settings created are for the auto run and the installation path. As a result, Remote Desktop Manager can be uninstalled easily.

You can run the uninstaller if it was installed with the default setup file, or delete the installation folder directly if it was installed from the binaries.

7.6 Add-ons

Description

Add-ons are used to extend the application. They are developed by using the Remote Desktop Manager SDK. There are multiple types of add-ons:

- Application tool add-ons
- Data source add-ons (MySQL)
- Import add-ons (Filezilla, SecureCRT, etc.)
- Session tools add-ons (remote shutdown, who is...)
- Session type add-ons (Java Web Start, SQL Management Studio, etc.)
- VPN add-ons (OpenVPN, Nortel VPN, etc.)
- Data entry add-ons

You can find the list here and download them directly from our website.

Add-on Manager
The Add-on Manager is available in the Tools menu of the Remote Desktop Manager.

It's used to simplify the management and the installation of different add-on types. It contains all of the add-ons that are supported by the current version of the application.

The add-ons are classified by category (session add-on, import add-on, data source add-on, etc.), and can be sorted according to their current status (available, outdated, uninstalled). Add-ons that can be updated will be displayed with a special and clearly visible icon.

If the add-on does not required any special third party library, the manager will deploy it automatically after clicking the install button. A restart of the application will still be required. The same procedure and limitation applies when uninstalling an add-on.

Add-on manager dialog

**Installing a New Add-on Manually**

1. Download the add-on you want (the binaries, not the source)
2. Unzip all files in the installation folder of Remote Desktop Manager, which is by default located in "C:\Program Files\Devolutions\RemoteDesktopManager\Program\bin\Release"
3. Restart Remote Desktop Manager
4. Create a new session with the newly installed add-on type, or use it if it's a custom tool or and import dialog

**Troubleshooting**

If you can't see the add-on in the session type list, verify that it's loaded in the About box, which is available from the menu in Help > About. Also verify that the .dll file is in the Remote Desktop Manager folder.

Some add-ons are supported directly by Devolutions, and some others are developed by a third party. You can find more information in the Add-On forum [here](#).

### 7.7 Configure SQL Server

**On the Server Machine**

1. Install or unzip Remote Desktop Manager Enterprise on the machine
2. Install SQL Server or SQL Server Express (this version is free) with the administrator user named "sa" (mixed mode authentication). Learn more at [http://remotedesktopmanager.com/remotedesktopmanager/Home.aspx/Download](http://remotedesktopmanager.com/remotedesktopmanager/Home.aspx/Download)
   - To create the Remote Desktop Manager database, you must use the user "sa" because domain users are not currently supported
   - Make sure to remember the SQL Server instance name, as you will need it for the connection
   - SQL Server 2000 is not supported by Remote Desktop Manager
3. Use your administrator user "sa" in Remote Desktop Manager to create an empty database.
   - To create an empty database, go to File>**Data Sources**
   - Configure the connection with the user "sa" and test the connection
   - Click the button "Create Database"
4. SQL Server ports are blocked by default, so follow this link to open the necessary ports and firewall: [http://support.microsoft.com/kb/914277](http://support.microsoft.com/kb/914277)
5. Create and configure security access for any other user needed in Remote Desktop Manager (menu File > Administration > Users)

**Client Machine**

1. Install or unzip Remote Desktop Manager Enterprise
2. Configure Remote Desktop Manager to connect directly to the SQL Server database (use the machine name and SQL Server instance name)
   - You can configure the connection in the menu: File > **Data Sources**
   - Click on the button "Add SQL Server Data source"
   - Configure the connection settings and test the connection (see the SQL Server data source topic [here](#))
FAQ (frequently asked questions)
8 FAQ (frequently asked questions)

Description

You can find the most up to date FAQs online here.
Technical support
9 Technical support

Commercial Version

If you've registered and paid for a license, you can obtain free support for Remote Desktop Manager. Please email any questions or suggestions to support@devolutions.net. You can also find answers and ask questions directly in our forums at http://forum.devolutions.net/.

Free Version

For the free version, we offer support through our online forums at http://forum.devolutions.net/.

Application Log

In case of error, you can verify the local application log, which is available from the menu in Help > View Application Log...
Follow us

Part X
10 Follow us

Facebook

http://facebook.remotedesktopmanager.com

LinkedIn

http://linkedin.remotedesktopmanager.com

RSS feeds

http://rss.remotedesktopmanager.com

Twitter

http://twitter.remotedesktopmanager.com

YouTube

http://youtube.remotedesktopmanager.com
Known issues

Part XI
11 Known issues

**Microsoft RDP Client**

Error message:

“Cannot copy <FileName>: Windows cannot find ‘%1!|s!’ Check the spelling and try again, or try searching for the item by clicking the Start button and clicking search”

This is a bug in the Microsoft Remote Desktop Client. The workaround is to enable the Smart Card even if it's not required for the connection.

**Unable to find mstsc.exe**

Vista 64-bit edition requires Service Pack 1

**VPN**

Missing opened VPN from list:

The opened VPN is not listed in Remote Desktop Manager. Unfortunately, there is no way for us to detect an already opened VPN session.
Index

- L -

LogMeIn  6